Autor Wątek: Problem z polską nakłądką do Benq E72  (Przeczytany 32793 razy)

Offline qolejowy

  • Swojak
  • ***
  • Podziękowań: 3
  • Benq E72, Nokia 6210 Navi.
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #15 dnia: Wtorek, 07 Kwiecień 2009, 18:53 »

Sekcja xip wyciągnięta ale po użyciu XIPPort  w folderze "nk.exe" mam tylko pliki
"imageinfo.bin, imageinfo.txt, S0000, S0001, S0002, S0003, S0004"
natomiast nie ma samego pliku "nk.exe" to samo jest w pozostałych  folderach.
Plik "initflashfiles.dat" rzeczywiście jest w sekcji xip tak samo mxip_lang.vol, mam te pliki pozostawić w xip?? czy je gdzieś przenieść.

nokser

  • Gość
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #16 dnia: Wtorek, 07 Kwiecień 2009, 18:58 »
Nawet jak je przerzucisz do SYS, to nic nie zmieni. Poprawną rzeczą będzie, jak initflaszfiles.dat przerzucisz do OEM_Lang_0xxx.
BuildOs, w takim przykładzie będzie poprawnie składał system ;)


Offline globalbus

  • GZU
  • Core
  • ****
  • Podziękowań: 77
  • N900 + Zest
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #17 dnia: Wtorek, 07 Kwiecień 2009, 19:52 »
Cytuj
Sekcja xip wyciągnięta ale po użyciu XIPPort  w folderze "nk.exe" mam tylko pliki
"imageinfo.bin, imageinfo.txt, S0000, S0001, S0002, S0003, S0004"
natomiast nie ma samego pliku "nk.exe" to samo jest w pozostałych  folderach.
bo tak ma być ;)
xipaddrtools jeśli chcesz coś tam podmienić


nokser

  • Gość
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #18 dnia: Wtorek, 07 Kwiecień 2009, 20:04 »
Po prostu kolega nie jest na etapie pojęcia - Co to Moduł a co Files :p

Offline qolejowy

  • Swojak
  • ***
  • Podziękowań: 3
  • Benq E72, Nokia 6210 Navi.
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #19 dnia: Wtorek, 07 Kwiecień 2009, 22:05 »
Po prostu kolega nie jest na etapie pojęcia - Co to Moduł a co Files :p
I tu masz rację, dopiero zaczynam zabawę w te klocki, pierwsze malutkie sukcesy już mam "nakładka spolszczająca tego Benqa"
Jak mam wrzucić te 0415 w soft?? mogę poprostu  pozmieniać wszystko w rejestrze na 0415 i podmienić MUI  (w telu mam tylko 0409)
ale ty byłoby chyba za proste?




Offline Mietas

  • Core
  • *****
  • Podziękowań: 53
  • Nokia Lumia 520, MDA Compact IV
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #20 dnia: Wtorek, 07 Kwiecień 2009, 22:08 »
Rozumiem, że tłumaczenie masz w plikach *0409.mui ... Po prostu podmień te twoje pliki za oryginalne, przeedytuj initflashfiles i gotowe.

Wiem wiem, że to niełatwe, ale spokojnie, nauczysz się :) Pierwsza podpowiedź: w initflashfiles.dat po wszelkich modyfikacjach musisz hexedytorem usunąć 2 pierwsze bajty z tegoż, inaczej cały build nie będzie działał.
Lumia 520, WP8 8.0.10211.250, oryginał Plus
MDA Compact IV, MLR 6.1

Offline qolejowy

  • Swojak
  • ***
  • Podziękowań: 3
  • Benq E72, Nokia 6210 Navi.
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #21 dnia: Wtorek, 07 Kwiecień 2009, 22:33 »
Rozumiem, że tłumaczenie masz w plikach *0409.mui ...

Pliki mam jako 0415 i tak chciałem je wrzucić i tu właśnie widzę problem bo w folderze z plikiem mui jest też plik "Imageinfo.txt" i jak wrzucę tam 0415 to podejrzewam że będzie kicha (mam w tym pliku podmienić nazwę na ....0415mui??)
Gdzieś wyczytałem żeby  initflashfiles.dat edytować np Notepad++ i wtedy tych bajtów nie trzeba usuwać, ale usunę je hexem.

Offline Mietas

  • Core
  • *****
  • Podziękowań: 53
  • Nokia Lumia 520, MDA Compact IV
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #22 dnia: Wtorek, 07 Kwiecień 2009, 22:35 »
Aa, no tak, moduły. Będzie trzeba przerobić je magicznym programem reversmode... Oj, będzie z tym trochę roboty.
Lumia 520, WP8 8.0.10211.250, oryginał Plus
MDA Compact IV, MLR 6.1

Offline qolejowy

  • Swojak
  • ***
  • Podziękowań: 3
  • Benq E72, Nokia 6210 Navi.
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #23 dnia: Wtorek, 07 Kwiecień 2009, 22:53 »
Aa, no tak, moduły. Będzie trzeba przerobić je magicznym programem reversmode... Oj, będzie z tym trochę roboty.
Wczoraj właśnie trochę czytałem o edycji modułów i próbowałem ale obojętnie jaki plik próbuję scalić dostaję taki komunikat mimo iż plik imageinfo.bin jest w folderze z plikiem syncres.dll.0415.mui
C:\Temp>nueRecMod syncres.dll.0415.mui\syncres.dll.0415.mui
Error! Cannot map syncres.dll.0415.mui\syncres.dll.0415.mui\imageinfo.bin

« Ostatnia zmiana: Wtorek, 07 Kwiecień 2009, 22:59 wysłana przez qolejowy »

nokser

  • Gość
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #24 dnia: Wtorek, 07 Kwiecień 2009, 22:59 »
Rozumiem, że tłumaczenie masz w plikach *0409.mui ... Po prostu podmień te twoje pliki za oryginalne, przeedytuj initflashfiles i gotowe.

Wiem wiem, że to niełatwe, ale spokojnie, nauczysz się :) Pierwsza podpowiedź: w initflashfiles.dat po wszelkich modyfikacjach musisz hexedytorem usunąć 2 pierwsze bajty z tegoż, inaczej cały build nie będzie działał.
No tak ale nie wystarczy tylko pozmieniać cyferki.... jeszcze nazwy katalogów, plików i polonizacja plików pozostałych.
Mniej więcej tak:
Polonizacja


Offline qolejowy

  • Swojak
  • ***
  • Podziękowań: 3
  • Benq E72, Nokia 6210 Navi.
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #25 dnia: Środa, 08 Kwiecień 2009, 00:43 »
No tak ale nie wystarczy tylko pozmieniać cyferki.... jeszcze nazwy katalogów, plików i polonizacja plików pozostałych.
Mniej więcej tak:
Polonizacja
Oki temat mam zapisany i znam go prawie na pamięć ale mi chodzi o coś innego
w folderze OEM\OEM_Lang_0409 są gołe pliki i te podmieniam i powinno być OK
natomiast w SYS\Base_Lang_0409  w folderach są same ...dll.0409.mui (to są chyba moduły? tak) i jak wrzucę tam plik 0415 zmienię mu nazwę na 0409 to taki plik zadziała?
próbowałem wczoraj zamienić te moduły na jeden plik narzędziem "nueRecMod.exe" ale wywala mi błąd o którym piszę w poście powyżej, co robię nie tak?

nokser

  • Gość
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #26 dnia: Środa, 08 Kwiecień 2009, 00:47 »
No tak ale nie wystarczy tylko pozmieniać cyferki.... jeszcze nazwy katalogów, plików i polonizacja plików pozostałych.
Mniej więcej tak:
Polonizacja
Oki temat mam zapisany i znam go prawie na pamięć ale mi chodzi o coś innego
w folderze OEM\OEM_Lang_0409 są gołe pliki i te podmieniam i powinno być OK
natomiast w SYS\Base_Lang_0409  w folderach są same ...dll.0409.mui (to są chyba moduły? tak) i jak wrzucę tam plik 0415 zmienię mu nazwę na 0409 to taki plik zadziała?
próbowałem wczoraj zamienić te moduły na jeden plik narzędziem "nueRecMod.exe" ale wywala mi błąd o którym piszę w poście powyżej, co robię nie tak?
Powinno grać.....
Do zmiany Pliku w Moduł i na odwrót masz w pobieralni MoToFi od Ham3r


Offline Mietas

  • Core
  • *****
  • Podziękowań: 53
  • Nokia Lumia 520, MDA Compact IV
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #27 dnia: Środa, 08 Kwiecień 2009, 07:38 »
Oj, i tu się mylisz NOKser...

MoToFi służy do zamiany MODUŁÓW na PLIKI. To narzędzie nic mu nie pomoże, tak jak i nueRecMod. Do zamiany PLIKÓW na MODUŁY używa się reversmode.
Lumia 520, WP8 8.0.10211.250, oryginał Plus
MDA Compact IV, MLR 6.1

nokser

  • Gość
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #28 dnia: Środa, 08 Kwiecień 2009, 10:56 »
No fakt, ale wydał ostatnio coś nowego i chyba pisał o tym...
No nie wiem - przecież ja jadę cały czas starymi technikami - reversmode - jednak nie każdy wie jak używać

Offline globalbus

  • GZU
  • Core
  • ****
  • Podziękowań: 77
  • N900 + Zest
Odp: Problem z polską nakłądką do Benq E72
« Odpowiedź #29 dnia: Środa, 08 Kwiecień 2009, 14:31 »
Cytuj
Wczoraj właśnie trochę czytałem o edycji modułów i próbowałem ale obojętnie jaki plik próbuję scalić dostaję taki komunikat mimo iż plik imageinfo.bin jest w folderze z plikiem syncres.dll.0415.mui
prościej, przeciągnij moduł ( nie plik) do recmod